Planet
navi homePPSaboutscreenshotsdownloaddevelopmentforum

Opened 12 years ago

Closed 12 years ago

#248 closed task (fixed)

Key mapping

Reported by: bknecht Owned by: rgrieder
Priority: major Milestone: Version 0.2 Codename: Bellatrix
Component: InputSystem Version: 0.2.0
Keywords: Cc:
Referenced By: References:

Description

Outline

It should be easy for the developers to assign a new key to a new function. Also it is important that a key input may have various results in a game depending in which state the game is. Pressing 'W' could hit the thrusters of a ship, let a person walk forward or write the character 'w' into the chat window.

Starting point

All we have is the basic input capture OIS delivered. It's on to you to find a easy way to solve that problem.

How to start

The problem is not THAT open as it sounds the first time you hear it. Ask x3n? for directions. He will propose to approaches, one with function pointers which will maybe the better one. This problem has yet to be discussed into more detail and that's where you come in.

Goal

Since you decide to a certain amount how to solve the problem, the goal is to implement your solution until it works.

Attachments (1)

optimus_oled_quake.jpg (31.4 KB) - added by bknecht 12 years ago.

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by bknecht

comment:1 Changed 12 years ago by rgrieder

  • Owner changed from nobody to rgrieder
  • Status changed from new to assigned

comment:2 Changed 12 years ago by bknecht

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.