Planet
navi homePPSaboutscreenshotsdownloaddevelopmentforum

Ignore:
Timestamp:
Jul 2, 2005, 6:28:26 PM (19 years ago)
Author:
bensch
Message:

orxonox/trunk: better ebuild, and the default data-dir can now be specified through ./configure —datadir=bla

File:
1 edited

Legend:

Unmodified
Added
Removed
  • orxonox/trunk/scripts/gentoo/orxonox-0.3.0_alpha-r4772.ebuild

    r4773 r4774  
    33# $Header: $
    44
    5 inherit eutils
     5inherit eutils games
     6
     7DATA_VERSION=65
    68
    79DESCRIPTION="orxonox is an open-source vertical scroller game programmed in C++, OpenGL, OpenAL and SDL"
    810HOMEPAGE="http://www.orxonox.ethz.ch"
    911SRC_URI="http://www.orxonox.ethz.ch/files/snapshots/${P}-${PR}.tar.bz2
    10          http://www.orxonox.ethz.ch/files/snapshots/data-r65.tar.bz2"
     12         http://www.orxonox.ethz.ch/files/snapshots/${PN}-data-r${DATA_VERSION}.tar.bz2"
    1113LICENSE="GPL-2"
    1214SLOT="0"
     
    2527S=${WORKDIR}/${P}
    2628
     29src_unpack() {
     30        unpack ${P}-${PR}.tar.bz2
     31        cd "${S}"
     32        unpack ${PN}-data-r${DATA_VERSION}.tar.bz2
     33}
     34
    2735src_compile() {
    28         econf || die "econf failed"
    29 
    30         #./configure \
    31         #       --host=${CHOST} \
    32         #       --prefix=/usr \
    33         #       --infodir=/usr/share/info \
    34         #       --mandir=/usr/share/man || die "./configure failed"
     36        egamesconf || die
    3537
    3638        emake || die "emake failed"
     
    3941src_install() {
    4042        make DESTDIR=${D} install || die
     43       
     44        dodir ${GAMES_DATADIR}/${PN}
     45        cp -r data/* ${D}/${GAMES_DATADIR}/${PN}/ \
     46                || die "data copy failed"
     47       
     48        dodoc AUTHORS ChangeLog README
     49
     50        prepgamesdirs
    4151
    4252        #make \
     
    4959        #einstall || die
    5060}
     61
     62pkg_postinst() {
     63        games_pkg_postinst
     64}
Note: See TracChangeset for help on using the changeset viewer.