Planet
navi homePPSaboutscreenshotsdownloaddevelopmentforum

source: orxonox.OLD/orxonox/trunk/scripts/gentoo/orxonox-0.3.0_alpha-r4772.ebuild @ 4774

Last change on this file since 4774 was 4774, checked in by bensch, 19 years ago

orxonox/trunk: better ebuild, and the default data-dir can now be specified through ./configure —datadir=bla

File size: 1.3 KB
Line 
1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5inherit eutils games
6
7DATA_VERSION=65
8
9DESCRIPTION="orxonox is an open-source vertical scroller game programmed in C++, OpenGL, OpenAL and SDL"
10HOMEPAGE="http://www.orxonox.ethz.ch"
11SRC_URI="http://www.orxonox.ethz.ch/files/snapshots/${P}-${PR}.tar.bz2
12         http://www.orxonox.ethz.ch/files/snapshots/${PN}-data-r${DATA_VERSION}.tar.bz2"
13LICENSE="GPL-2"
14SLOT="0"
15KEYWORDS="x86"
16IUSE="gtk+-2"
17
18DEPEND="virtual/opengl
19        virtual/x11
20        media-libs/openal
21        media-libs/libsdl
22        media-libs/sdl-image
23        media-libs/sdl-ttf"
24
25# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
26#RDEPEND=""
27S=${WORKDIR}/${P}
28
29src_unpack() {
30        unpack ${P}-${PR}.tar.bz2
31        cd "${S}"
32        unpack ${PN}-data-r${DATA_VERSION}.tar.bz2
33}
34
35src_compile() {
36        egamesconf || die
37
38        emake || die "emake failed"
39}
40
41src_install() {
42        make DESTDIR=${D} install || die
43       
44        dodir ${GAMES_DATADIR}/${PN}
45        cp -r data/* ${D}/${GAMES_DATADIR}/${PN}/ \
46                || die "data copy failed"
47       
48        dodoc AUTHORS ChangeLog README
49
50        prepgamesdirs
51
52        #make \
53        #       prefix=${D}/usr \
54        #       mandir=${D}/usr/share/man \
55        #       infodir=${D}/usr/share/info \
56        #       libdir=${D}/usr/$(get_libdir) \
57        #       install || die
58
59        #einstall || die
60}
61
62pkg_postinst() {
63        games_pkg_postinst
64}
Note: See TracBrowser for help on using the repository browser.