Planet
navi homePPSaboutscreenshotsdownloaddevelopmentforum

source: orxonox.OLD/orxonox/trunk/scripts/gentoo/orxonox-0.3.0_alpha-r4772.ebuild @ 4773

Last change on this file since 4773 was 4773, checked in by bensch, 19 years ago

orxonox/trunk: added gentoo-ebuild, that works for getting the source and the data, and installing the source

File size: 1.1 KB
Line 
1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5inherit eutils
6
7DESCRIPTION="orxonox is an open-source vertical scroller game programmed in C++, OpenGL, OpenAL and SDL"
8HOMEPAGE="http://www.orxonox.ethz.ch"
9SRC_URI="http://www.orxonox.ethz.ch/files/snapshots/${P}-${PR}.tar.bz2
10         http://www.orxonox.ethz.ch/files/snapshots/data-r65.tar.bz2"
11LICENSE="GPL-2"
12SLOT="0"
13KEYWORDS="x86"
14IUSE="gtk+-2"
15
16DEPEND="virtual/opengl
17        virtual/x11
18        media-libs/openal
19        media-libs/libsdl
20        media-libs/sdl-image
21        media-libs/sdl-ttf"
22
23# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
24#RDEPEND=""
25S=${WORKDIR}/${P}
26
27src_compile() {
28        econf || die "econf failed"
29
30        #./configure \
31        #       --host=${CHOST} \
32        #       --prefix=/usr \
33        #       --infodir=/usr/share/info \
34        #       --mandir=/usr/share/man || die "./configure failed"
35
36        emake || die "emake failed"
37}
38
39src_install() {
40        make DESTDIR=${D} install || die
41
42        #make \
43        #       prefix=${D}/usr \
44        #       mandir=${D}/usr/share/man \
45        #       infodir=${D}/usr/share/info \
46        #       libdir=${D}/usr/$(get_libdir) \
47        #       install || die
48
49        #einstall || die
50}
Note: See TracBrowser for help on using the repository browser.