Planet
navi homePPSaboutscreenshotsdownloaddevelopmentforum

Opened 11 years ago

Closed 11 years ago

#290 closed defect (fixed)

Buildsystem branch without ogre.cfg

Reported by: rgrieder Owned by: nobody
Priority: blocker Milestone: Version 0.2 Codename: Bellatrix
Component: GraphicsEngine Version: 0.2.0
Keywords: ogre, buildsystem Cc:
Referenced By: References:

Description

The last time I checked the build system branch on tardis, we've had trouble running it without ogre.cfg. This is the config file that Ogre creates when you first start orxonox. You are then prompted for some parameters which are written to ogre.cfg. After that you don't need to do that again.

The problem then is that we never let the user create his own ogre.cfg until now. This is crap however. Changing the resolution is everything else than convenient (you'll have to edit ogre.cfg yourself). In the build system branch I "resolved" that problem by removing ogre.cfg. This is bit of a problem since Ogre can't find the necessary files when trying to show to dialog for options.

This has to be inspected thoroughly as soon as possible. It is especially important to see whether the problem only occurs on tardis. I can confirm that it works on my visual studio with windows combination.

Change History (1)

comment:1 Changed 11 years ago by rgrieder

  • Resolution set to fixed
  • Status changed from new to closed

Resolved: The tardis boxes have been updated to debian 4.0, causing trouble with the OGRE version compiled for debian 3.1
The ISG.ee was kind enough the OGRE library (and some others) for us ;)

Note: See TracTickets for help on using tickets.