Planet
navi homePPSaboutscreenshotsdownloaddevelopmentforum

Version 3 (modified by Naaduun, 11 years ago) (diff)

ArchLinux

You need to know how to create and install a package using PKGBUILD file. See http://wiki.archlinux.org/index.php/Makepkg for usage.
In short: Grab the file and run:

makepkg
pacman -U packagename.tar.gz

Dependencies

Orxonox needs Tcl-8.5.2. You can download the Makepkg file from the official SVN repository:

Building

You can use this script to build Orxonox from SVN.

Troubleshooting

Compile failed, xxx needs fPIC flag

enet may need to rebuild using fPIC flag. Add -fPIC to the CFLAGS variable in /etc/makepkg.conf and rebuild the package. You can find the PKGBUILD in aur: http://aur.archlinux.org/packages.php?ID=8842