Planet
navi homePPSaboutscreenshotsdownloaddevelopmentforum

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#459 closed defect (fixed)

Solve roundcube login issues

Reported by: lferran Owned by: lferran
Priority: critical Milestone: IT: Server Setup
Component: IT Version:
Keywords: Cc:
Referenced By: References:

Description (last modified by landauf)

Problems:

  • When users login only using their userid, the roundcube treats the user as <userid>@localhost instead of @orxonox.net
  • This causes that the user, then, can't send any email.

Change History (3)

comment:1 Changed 4 years ago by lferran

  • Resolution set to fixed
  • Status changed from new to closed

Dovecot drops the domain part of the username input given by roundcube ⇒ If the input is lferran@… authentication is only done with lferran.

The problem was solved by modifying the ldap filter in the dovecot configuration. In /etc/dovecot/dovecot-ldap.conf.ext:

# pass_filter = "(&(objectClass=PostfixBookMailAccount)(uniqueIdentifier=%n)) # prev. filter

pass_filter = "(&(objectClass=PostfixBookMailAccount)(uniqueIdentifier=%n)(mail=%u))"

Now, when roundcube has a new user@… + password to validate:

  1. Sends the credentials to Dovecot
  2. Dovecot performs a ldap bind
  3. Dovecot searches for user@… in the ldap directory and compares the password

More information about how this issue has been solved here.

Last edited 4 years ago by landauf (previous) (diff)

comment:2 Changed 4 years ago by lferran

Best and final solution:

modify roundcube configuration parameter that acts as default_domain in case the user does not write it in the login form:

$rcmail_config['username_domain'] = 'orxonox.net';
Last edited 4 years ago by landauf (previous) (diff)

comment:3 Changed 4 years ago by landauf

  • Description modified (diff)
Note: See TracTickets for help on using tickets.