Planet
navi homePPSaboutscreenshotsdownloaddevelopmentforum

Opened 15 years ago

Closed 14 years ago

Last modified 13 years ago

#109 closed defect (fixed)

menu-screen

Reported by: bensch Owned by: bensch
Priority: major Milestone: Old Orxonox tickets orx-v0
Component: GUI Version:
Keywords: Cc:
Referenced By: References:

Description

Menu-Screen

idea

like all games orxonox too needs a start-screen. The Startscreen is a menu, where the user can:

  • choose a profile (later stage)
  • start a new Game
  • choose some settings
  • quit the game

implementation

The problem is, to define a new Class named MenuSreen, that is like world a Loop-class, that

  1. displays the GUI
  2. checks for input events
  3. acts on them.
  4. maybe display a cool background (animated)

Settings should be saveable. → use the GUI class to write directly to the orxonox.conf file. maybe save some states, and default values.

considerations

for the menu-screen to work properly, context-switches might be nice, e.g.

  • see #110 for more info on this topic

Change History (3)

comment:1 Changed 14 years ago by patrick

  • Milestone changed from 0.3.5_playability to 0.3.7_gui

comment:2 Changed 14 years ago by bensch

  • Resolution set to fixed
  • Status changed from new to closed

acceptable version is implemented

comment:3 Changed 13 years ago by bknecht

  • Milestone changed from GUI and Installers to Old Orxonox tickets

Milestone GUI and Installers deleted

Note: See TracTickets for help on using tickets.