Planet
navi homePPSaboutscreenshotsdownloaddevelopmentforum

source: code/trunk/INSTALL @ 8473

Last change on this file since 8473 was 8473, checked in by rgrieder, 8 years ago

Corrected library version requirements.

  • Property svn:eol-style set to native
File size: 1.2 KB
Line 
1************* Build System **************
2To make platform support as easy as possible we have decided to use CMake as our build system.
3Therefore the first thing you need to do is to get
4CMake v.2.6 or later.
5
6************** Libraries ****************
7
8In order to compile Orxonox you will need the following libraries:
9(for windows there are already precompiled packages on the website)
10
11OGRE 3D Graphics Engine          1.6 - 1.7
12CEGUI (Crazy Eddie's GUI System) 0.6 - 0.7
13Boost libraries                  1.40 -
14Lua (scripting language)         5.1
15Tcl (shell script language)      8.4 - 8.5
16OpenAL (audio)                   (no version requirements specified yet)
17ALUT (audio)                     (no version requirements specified yet)
18LibOgg                           (no version requirements specified yet)
19LibVorbis                        (no version requirements specified yet)
20ZLib (compression)               (no version requirements specified yet)
21
22OGRE supports both OpenGL and DirectX9 rendering. You will also need OGRE for the dedicated server!
23
24Further information about installing and running this application can be found on
25http://www.orxonox.net/wiki/Running
Note: See TracBrowser for help on using the repository browser.