Planet
navi homePPSaboutscreenshotsdownloaddevelopmentforum

source: orxonox.OLD/trunk/scripts/gentoo/orxonox-0.3.1_alpha-r5273.ebuild @ 5274

Last change on this file since 5274 was 5274, checked in by bensch, 19 years ago

orxonox/trunk: new ebuild

File size: 1.5 KB
Line 
1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5inherit eutils games
6
7DATA_VERSION=83
8
9DESCRIPTION="orxonox is an open-source 3D-action game programmed in C++, OpenGL, OpenAL and SDL"
10HOMEPAGE="http://www.orxonox.net"
11SRC_URI="http://www.orxonox.net/files/snapshots/${P}-${PR}.tar.bz2
12         http://www.orxonox.net/files/snapshots/${PN}-data-r${DATA_VERSION}.tar.bz2"
13LICENSE="GPL-2"
14SLOT="0"
15KEYWORDS="x86"
16IUSE="gtk+-2"
17
18DEPEND="virtual/opengl
19        virtual/x11
20        media-libs/openal
21        media-libs/libsdl
22        media-libs/sdl-image
23        media-libs/sdl-ttf
24        media-libs/glew"
25
26# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
27#RDEPEND=""
28S=${WORKDIR}/${P}
29
30src_unpack() {
31        unpack ${P}-${PR}.tar.bz2
32        cd "${S}"
33        unpack ${PN}-data-r${DATA_VERSION}.tar.bz2
34}
35
36src_compile() {
37        egamesconf || die
38
39        emake || die "emake failed"
40}
41
42src_install() {
43        make DESTDIR=${D} install || die
44
45        dodir ${GAMES_DATADIR}/${PN}
46        cp -r data/* ${D}/${GAMES_DATADIR}/${PN}/ \
47                || die "data copy failed"
48
49        dodoc AUTHORS ChangeLog README
50
51        prepgamesdirs
52
53        #make \
54        #       prefix=${D}/usr \
55        #       mandir=${D}/usr/share/man \
56        #       infodir=${D}/usr/share/info \
57        #       libdir=${D}/usr/$(get_libdir) \
58        #       install || die
59
60        #einstall || die
61}
62
63pkg_postinst() {
64        games_pkg_postinst
65}
Note: See TracBrowser for help on using the repository browser.