Planet
navi homePPSaboutscreenshotsdownloaddevelopmentforum

source: orxonox.OLD/orxonox/trunk/scripts/orxonox.ebuild @ 4772

Last change on this file since 4772 was 4772, checked in by bensch, 19 years ago

orxonox/trunk: more gentoo-like revision-number (0.3.0_alpha)

File size: 835 bytes
Line 
1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5inherit games
6
7DESCRIPTION="orxonox is an open-source vertical scroller game programmed in C++, OpenGL, OpenAL and SDL"
8HOMEPAGE="http://www.orxonox.ethz.ch"
9SRC_URI="http://www.orxonox.ethz.ch/files/snapshots/${PN}${PV}-${PR}.tar.bz2"
10
11KEYWORDS="x86"
12LICENSE="GPL-2"
13SLOT="0"
14IUSE=""
15
16
17DEPEND="virtual/opengl
18        virtual/x11
19        media-libs/openal
20        media-libs/libsdl
21        media-libs/sdl-image
22        media-libs/sdl-ttf"
23
24
25src_compile() {
26        econf || die "could not configure"
27        emake || die "emake failed"
28
29}
30
31src_install() {
32      into /usr
33      doinfo doc/orxonox.info
34      doman doc/orxonox.1
35      into /
36      dobin orxonox/orxonox || die "dobin orxonox failed"
37      dodir /usr/bin/games
38}
Note: See TracBrowser for help on using the repository browser.