Planet
navi homePPSaboutscreenshotsdownloaddevelopmentforum

source: downloads/tcl8.5.2/unix/tcl.spec @ 25

Last change on this file since 25 was 25, checked in by landauf, 16 years ago

added tcl to libs

File size: 1.4 KB
Line 
1# $Id: tcl.spec,v 1.37 2008/03/28 17:31:48 dgp Exp $
2# This file is the basis for a binary Tcl RPM for Linux.
3
4%{!?directory:%define directory /usr/local}
5
6Name:          tcl
7Summary:       Tcl scripting language development environment
8Version:       8.5.2
9Release:       2
10License:       BSD
11Group:         Development/Languages
12Source:        http://prdownloads.sourceforge.net/tcl/tcl%{version}-src.tar.gz
13URL:           http://www.tcl.tk/
14Buildroot:     /var/tmp/%{name}%{version}
15
16%description
17The Tcl (Tool Command Language) provides a powerful platform for
18creating integration applications that tie together diverse
19applications, protocols, devices, and frameworks.  When paired with
20the Tk toolkit, Tcl provides the fastest and most powerful way to
21create GUI applications that run on PCs, Unix, and Mac OS X.  Tcl
22can also be used for a variety of web-related tasks and for creating
23powerful command languages for applications.
24
25%prep
26%setup -q -n %{name}%{version}
27
28%build
29cd unix
30CFLAGS="%optflags" ./configure \
31        --prefix=%{directory} \
32        --exec-prefix=%{directory} \
33        --libdir=%{directory}/%{_lib}
34make
35
36%install
37cd unix
38make INSTALL_ROOT=%{buildroot} install
39
40%clean
41rm -rf %buildroot
42
43%files
44%defattr(-,root,root)
45%if %{_lib} != lib
46%{directory}/%{_lib}
47%endif
48%{directory}/lib
49%{directory}/bin
50%{directory}/include
51%{directory}/man/man1
52%{directory}/man/man3
53%{directory}/man/mann
Note: See TracBrowser for help on using the repository browser.