Planet
navi homePPSaboutscreenshotsdownloaddevelopmentforum

source: code/branches/map/archlinux/PKGBUILD @ 2838

Last change on this file since 2838 was 2838, checked in by Naaduun, 15 years ago

Added PKGBUILD for building package in Archlinux. See http://www.orxonox.net/wiki/LinuxArchLinux

File size: 714 bytes
Line 
1pkgname=orxonox-svn
2pkgver=2826
3pkgrel=1
4pkgdesc="Orxonox - the hottest 3D action shooter ever to exist"
5arch=('i686' 'x86_64')
6url="http://www.orxonox.net/"
7license=('GPL')
8depends=('ogre-branch-1.4' 'tcl' 'cegui' 'enet' 'boost' 'freealut' 'libvorbis')
9makedepends=('subversion' 'cmake')
10conflicts=('orxonox')
11provides=('orxonox')
12source=()
13md5sums=()
14
15_svntrunk=http://svn.orxonox.net/orxonox/trunk
16_svnmedia=http://svn.orxonox.net/data/media
17_svnmod=orxonox
18
19build() {
20  cd $startdir/src
21  svn co $_svntrunk $_svnmod
22  cd $_svnmod
23  svn co $_svnmedia
24  mkdir build
25  cd build
26  msg "Starting build..."
27  cmake ..
28  make || return 1
29  make DESTDIR=${startdir}/pkg install
30  #rm -rf $startdir/src/$_svnmod/build
31}
Note: See TracBrowser for help on using the repository browser.