Planet
navi homeaboutscreenshotsdownloaddevelopmentforum

Blender Knowledge Base

This page is a collection of various problems and strategies in Blender. Feel free to add items!

Dos

  • If available, use reference images or sketches as background images. ("View" → "Backgroud Image…")
  • Use symmetries. If your final model will be symmetrical or almost symmetrical, then you don't have to model both sides. Use the Mirror modifier instead and add minor details after finishing the rough symmetric shape.
  • When adding details to your object, try to save faces. Keep an eye on the face count in the info bar at the top. A guideline for the number of polygons is here.
  • Don't smooth edges with acute angles. Subdivide instead, if you want it more round. However, smoothing is very helpful for nearly planar edges.
  • Make sure, all normals point outside, otherwise your model might be rendered incorrectly. Select all faces in Edit Mode and hit Ctrl + N to recalculate the normals outside.
  • Optimize your model in the end in terms of polygon and vertex count.

Dont's

  • Don't leave holes in your mesh. Use F or Shift + F instead to fill them.
  • Double vertices, edges and faces. In Edit Mode, you can remove double vertices by selecting all and hitting W → Remove doubles.
  • Non-manifold edges, that means edges that do not have exactly 2 adjacent faces. To see which edges are non-manifold, switch to edge selection mode in Edit Mode and choose Select → Non-manifold.
  • Vertices in plain air.
  • Unconnected submeshes. Make sure, that meshes are fully connected and not just submeshes, that are joined together to form one pink-bordered object.

Frequently Asked Questions

How can I tell Blender to use relative file paths?

From the File Menu, pick External Data and there, pick Make all Paths Relative. This changes all paths in your current scene to relative paths. In order to do this, you must first save your work to a blend file.

This function is very handy, when you load your scenes on different computers. There will be no need to reload the textures for your models.

How can I manipulate numerically?

Activate your modificator (e.g. E to extrude, G to move, …) then just input a numeric value. In the header of the 3D-View, you will get numerical feedback. Hit Enter to confirm or ESC to abort the modification.

Alternatively, press N to bring up the "Transform Properties" window. It gives you numerical info location, dimension and rotation of your object and you can also enter numerical values there.

How can I set back or bottom view?

Holding the mouse over your 3D Viewport and pressing the NUM7, NUM1 or NUM3 buttons will bring you back to perfectly aligned top, front, and side views. Pressing CTRL+NUM7, CTRL+NUM1, and CTRL+NUM3 will result in displaying the bottom, back, and other side views, respectively.

How can I manipulate my pivot of my mesh?

You can choose the pivot point for rotating, spinning and similar functions by selection an option from the drop-down menu in the header of the 3D-View. The default is "Median Point" but you can also pick other options like "3D-Cursor" to place the pivot point freely with the 3D-Cursor.

How can I render my 3d view instead of the camera view?

  • Switch to Object mode
  • Open Render Preview: "View" → "Render Preview"
  • Move/Resize? the window to your likings,
  • Right-click the window to render a preview. Note that it often doesn't have the quality of a normal render, but it is useful to get an idea of what the render will look like.

How can I change the grid distance for the "Snap-to-Grid" function?

Zoom in and the grid distance will change automatically. Verify by switching to top/side/front view by hitting 1/3/7 on the numberpad.

How can I check my normals?

  • Edit Mode → F9
  • Under "Mesh Tools 1", click on "Draw Normals". The blue lines that appear are your face normals. You want them to point outside of the mesh.
  • Selecting a face and choosing W → "Flip Normals" lets you change them all individually.
  • You can also select all your faces and hit Ctrl + N to make them all point outside.

How do I delete materials?

All materials without "users" (that is, arent assigned to any objects) automatically get deleted when you re-load the blend.

So, if you want to delete a material, just remove it from all of your objects (so, when you look at the material popup selector the material name has a 0 nexto to it), save your .blend and reopen it. the unused materials should be deleted

Last modified 8 years ago Last modified on Apr 1, 2009, 8:35:43 PM